
Introduction to DERIVE 
 
The computer algebraic system DERIVE (CAS DERIVE) is often described as a “mathematical 
assistant”. It is a powerful and easy-to-use computer package for solving a range of mathematical 
problems. The aim of this introduction is to present some of the basic functions and commands in 
DERIVE. 
 
1. The DERIVE window. 
 
When you start DERIVE a window like this will appear: 
 

he window of DERIVE is similar to other basic programs run under WINDOWS.  

hat you see is the so called algebraic window. It is used for writing and working with algebraic 

ERIVE has both 2D and 3D graphic windows. 

 the next few paragraphs you will find out how to enter and work with algebraic expressions, 

 
T
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expressions, equations and formulas. In the lower part of the window there is a narrow, long field 
where inputs are made. We will call it input field. There are two groups of buttons under it. The left 
group consists of both capital and lower case Greek letters, and the right one contains the basic 
mathematical symbols. 
 
D
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equations and how to draw graphics.  
 



2. Entering expressions in DERIVE. 

fter starting DERIVE usually the marker is in the input field. If the marker is not there, then left click 

. Enter the expression 

 
A
in the field using your mouse. You are now ready to enter expressions or equation in DERIVE. 
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+−I . To do this, in the input field you have to write 1/4 - 6/12 + 9/17. 

ote 1:  
hen you are entering expressions in DERIVE you can use all the standard keys of the keyboard for 

, →, Home, End, Backspace(←) and Delete. 

 Press Enter. 
he following will appear on the screen: 

 

Press the Enter key on your keyboard.  
The following will appear on the screen 
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editing: ←
 
II. Enter the expression 927: In the input field, write 9^27.
T
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xIII. Enter the expression : Write (x – 4)/(x^2 – 9x +20). Press Enter. 

r on the sc
 
The following will appea reen: 

 
IV. Now enter the expression 
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 on your own. 

. Pay attention to where and how you place the brackets. When entering expressions and equations 
an only use the following type of brackets: ( ). Do not use square brackets: [ ]. They are 

2. 

to edit it. In order to do this, you need to: 

- 
 
 

. Enter on your own the following expression: 

 
Note 2:  
1

you c
reserved for entering vectors and matrices. 
After pressing Enter check whether the expression appearing on the screen looks like the one you 
have entered. 

3. If the expression appearing on the screen is not the same as the expression that you have entered, 
then you need 
- Double click the number of the row where the expression is located. In the input field a copy of 

this expression will appear.  
- Perform the necessary corrections and press Enter.  

Go back to step 2. 
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Note 3:  
In order to enter ,  select one of the following t nswo optio : 

ption I: Enter sqrt and then write in brackets the expression under the square  root i.e. 
rt(d^2 – f^2)/(d – f) ↵. 

 fi e button

O
 Enter  sq

 Option II: In the eld with mathematical symbols click on th  and the sign for square root 
 root i.e. will appear in the input field. After that, write in brackets the expression under the square

 Enter  (d^2 – f^2)/(d – f) ↵. 
 
VI. When working using the scheme given in step 3 from note 2, edit the expression in such a way so 

as to get
fd
fd − 22

. 
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3. Simplifying expressions in DERIVE. 

e will now use DERIVE to simplify each of the expressions entered so far. 

. Simplify 

 
W
 
I 971

17124
+− . Highlight the expression 

17124
ocated in using the left mouse button. Select from the menu Simplify. After th

971
+− , by clicking the number of the row it is 

at, select Basic.  
the follow

l
You will get ing result: 

51
.  

 
Note 4:  

10

E uch that it gives the result in the form of a fraction. 
. From now on when we want to specify that several operations are to be successively carried out, as 

 case of simplifying

1. The default setting for DERIV is s
2

in the
17124
971

+− , this is facilitated in the following way: Highlight the 

expression 
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+−  >  Simplify > Basic. 

ss button Ζ. 

 
Enter the result in the form of a decimal number: Highlight the row in which the fraction is located > 
Pre
 

Now we will demonstrate a different, faster method for simplifying expressions using button . 
 

II. Highlight the expression 927 > Press button .  
You will get the following result: 
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III. Simplify on your own the expressions
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, by highlighting each 

f them and using the button o . You should obtain respectively: 
  
 
 



 
elete all expressions entered so far by highlighting them one by one and pressing Delete for each of 

. Factorization

D
them. 
 
 
3 . 

. Factorize the expression Enter the expression > Press Simplify > Factor > 

 get the following result:  

. Expanding brackets

 
I 1827172 23 ++− xxx : 
Factor. 
You will

 
4 . 

. Expand the brackets in the expression (3x – 5)(2x – 1)(4x – 3):  Enter the expression  > Press 

. Entering and solving equations in DERIVE

 
I
Simplify > Expand > Expand. You will get: 
 

II. Expand the brackets in the expression ( )105+x . 
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 x^2 + 5x + 6 > press Solve > Expression > 
olve. You will get the following result: 

 order to solve any equation which is in the form f(x) = 0, it is not necessary to write “= 0” at the end, 
nly necessary to enter the expression f(x) and to press Solve > Expression > Solve. 

xpression 
++− xxx nter it again. Perform the following operations: 

w which contains 
- If the inpu e input field 

ression which is re > Delete it by pressing 

- 
- ter. We’re now ready to solve the equation.  

n point I. 

 

 
I. Solve the equation 0652 =++ xx : Enter the expression
S

 
Note 5: 
In
i.e. it is o
 
II. Solve the equation 1827172 23 ++− xxx  = 0. Since in step 4 we have already entered the e

23 182717 , it is not necessary to e
- Highlight the ro the expression 1827172 23 ++− xxx   

t field is not empty, then empty it by doing the following: Click in th

2

using the right mouse button and highlight the exp the
Delete. 
Press F3 and the desired expression 1827172 23 ++− xxx  will appear in the input field.  
Press En

- Solve it using the instructions given i
 



6. T nra sposition of formulas. 
 
I. Enter the formula 

au
p

−
= . Hu16 ere the variable p is expressed using the variables u and a. If we want 

 express the variable а using u and p, then it is necessary to do the following: Enter the expression to

au
up
−

=
16  > Press Solve > Expression > In Solution Variables highlight the variable а > Solve. 

You will get the following result: 

 
II. Now transpose the given formula so that u is expressed using a and p.
 

 

 
7.  Substitution. 
 
Enter the formula . Substitute the variables on the right with the following values 

. To do this: Enter the formula > press button

( )na θ1ρ +=

5=  ,3/1=θ,10= nρ  . 

 n
- Highlight the 0; 

 New Value: and enter 1/3.  
Yo i

. Plotting graphs

In the window which appears, do the following:  
- Highlight the variable  > click in the field New Value: and enter 5; 

variable 〈 > click in the field New Value: and enter 1
- Highlight the variable ¬ > click in the field

u w ll get the following result: 

Now write down the result in the form of a decimal number. 
 
Delete everything entered so far.  
 
 
8 . 

. Plot the graph of the function

 

I y x= −3 2 : Enter 3x – 2 > Press button  .  

perations a new window will appear –  a graphical window, which will cover the 
lgebraic window which we have been working with until now. In the graphical window you can see a 

 
s a result of these oA

a
coordinate system. 
 

Press again button  and the plot of y x= −3 2  will be displayed on the coordinate system given, 
as shown below. 
 



 
II. Plot the graph of the function y x= +5  in the same coordinate system.  
You have to get the following result: 

 
Note 6: 
1. In order to go back to the algebraic window, use button  . 
2. If you want to see the algebraic and graphical windows at the same time, do the following: From 

the menu select Window > Tile vertically.  
3. In order to switch between windows you just have to click in the window in which you would like 

to work at any time. 
 
III. Find the coordinates of the points of intersection of the two graphics. 
 
First do this graphically:  

1. In the graphical window use buttons  in order to see the point of 
intersection of the two lines.  

2. Click on button . In one of the graphs a small circle will appear. Using keyboard keys ↓ and ↑ 
you can transfer this circle from one graph to the other. Using keys ←, → you can move the circle 
within the graphic where it is located. 

3. Move the circle to the point of intersection of the two lines. In the left corner under the graphic you 
can will see the coordinates of this point: Cross: 3.541667, 8.541667 



 
Now find the coordinates of the point of intersection analytically, by solving the system of equations 
for the two lines: 
1. Switch to the algebraic window. 
2. From the menu choose Solve > System.  
3. In the small window which appears you have to indicate the number of the equations in the system 

which you are going to solve: In the Number: write 2 > Ok. 
4. A new window will appear, in which you have to indicate the two equations. Since these equations 

have already been entered you will not need to enter them again. All you need to do is to enter the 
number of the rows in which they are located, in this case #1 and #2, as shown below. Press Solve. 

 
5. You will get the following result : 



 
 Write the result using decimal numbers.  
 
II. Draw the parabola  and the liney x= 2 y x= +2 24 . Find the coordinates of their points of 
intersection, first graphically and then analytically. 
 
Close the graphical window. Empty the algebraic one by highlighting all the expressions and press 
Delete. Maximize it by double clicking the blue field on top. 
 
 
9. Differentiation. 
 

I. Find the derivative of the function ( ) 23 23 ++= xxxf : Enter  > Press 23 23 ++ xx  > 
Variable: x > Order: 1 > Simplify. 
You will get the following: 
 

I. Find the derivative of the function

0. Integration

 
I ( ) xxxf sin= 3 . 
 
 
1 . 

. Calculate an indefinite integral from the function : Click the number of the row in 
 
I ( ) xxxf 6+3= 2

which the expression is located xx 6+3 2 > Press  > Variable: x > 

ng: 

epeat the procedure but this time enter c in the field Constant: in the window which appears after 

Select an indefinite integral 
Indefinite > Simplify. 
You will get the followi

 
R

you press . you will get the following: 
 

 
II. Calculate the indefinite integral for the function ( ) xxxf sin= 3 . 
 
 
 



11. Entering text in the DERIVE window. 

wing: 
. If the algebraic window is empty, then select from the menu Insert > Text object > Click in the 

of New Text Objects > Select the font you want (Font) > Switch to Cyrillic > 

 
 
2. Some useful keys

 
In order to enter text in DERIVE, do the follo
1

rectangle which appears and enter your text. 
2. If the algebraic window is not empty, then highlight the row after which you wish to enter the text 

and repeat step 1. 
3. If you wish to write in Bulgarian, then even before you click Insert, select from the menu Options 

> Display > Font 
Perform respectively step1 or step 2, depending on the situation at hand. 

1 : 

ge 
 

Key Usa
F3 Copies a highlighted expression from the algebraic window to the input field. 
F4 The same as F3, but the expression in the input field will be put in brackets. 
F1 Hotkey for calling up the Help menu. 
Ctrl E Hotkeys for entering the exponential е. 
Ctrl P Hotkeys for entering π. 
Ctrl Q Hotkeys for entering square root. 
Ctrl I Hotkeys for entering the imaginary unit i. 

 
 
3. Some useful built in functions of DERIVE1 .  

XP(z) – the exponent from the expression z, i.e.  (When you are entering , instead of EXP(z), 
sion ⎢^z). 

N(z) – Natural logarithm from the expression z(z > 0). 
thm from the expression z(z > 0). 

 > 0). 
ase a. 

IN(z) – sin z 

 

etric functions: 
SIN(z) – arcsin z 

 

ry for the names of the functions to be written in capital letters. 

 
Exponential function: 

ze zeE
you can enter the expres
 
Logarithm functions: 
L
LOG(z) – Natural logari
LOG(z, 10) – Decimal logarithm from the expression z(z
LOG(z, a) – Logarithm from the expression z(z > 0) with b
 
Trigonometric functions: 
S
COS(z) – cos z 
TAN(z) – tg z 
COT(z) – cotg z
 
Inverse trigonom
A
ACOS(z) – arccos z 
ATAN(z) – arctg z 
ACOT(z) – arccotg z
 
Note 8: It isn’t necessa
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